[Résolu] Plus de connexion site boursier / Installation Linux

Aide, anomalies, ...
Ahoc
Messages : 11
Enregistré le : ven. 23 avr. 2021 10:47
Année de naissance : 1953

[Résolu] Plus de connexion site boursier / Installation Linux

Message par Ahoc »

Bonjour à tous
Je suis nouveau sur le forum, bien qu'utilisant Mérops depuis des années.
Je suis sous Linux, Xubuntu 20-04 Lts - Mérops version 10.173 32 bits - fonctionnant via Wine.

Mon problème :
Depuis quelques jours, lorsque je clic droit sur une action et que je veux aller sur le site boursier,
rien ne sa passe, pas de connexion. Par contre, les mises à jours des cours fonctionnent correctement.
Capture d’écran_2021-04-23_11-04-57.png
Capture d’écran_2021-04-23_11-04-57.png (70.42 Kio) Vu 3765 fois


Merci d'avance pour votre aide.
Bien cordialement.
Modifié en dernier par Ahoc le lun. 26 avr. 2021 22:24, modifié 1 fois.
Mérops
Site Admin
Messages : 4383
Enregistré le : jeu. 18 nov. 2004 23:12
Année de naissance : 1972
Localisation : Loire atlantique
Contact :

Re: Plus de connexion site boursier

Message par Mérops »

Bonjour Ahoc,

Il faudrait que tu installes un ActiveX Mozilla.
L'aide de Mérops sur Linux :
https://www.merops.com/linux.php

Mérops, :wink:
Ahoc
Messages : 11
Enregistré le : ven. 23 avr. 2021 10:47
Année de naissance : 1953

Re: Plus de connexion site boursier

Message par Ahoc »

Bonjour Mérops,
Comment vérifier si Gecko est installé sur mon système et comment l'installer,
il ne figure pas dans les dépots. J'ai regardé sur le web et je ne trouve rien sur
le façon de l'installer ni sur ActiveX.
pour info, l'affichage des journaux se fait correctement (Editions des ptf-journaux des évènements-tableaux des transcations - etc..)
Ce n'est que l'accès au site boursier Abc bourse pour une valeur donnée qui ne fonctionne pas.
Amitiés.
Mérops
Site Admin
Messages : 4383
Enregistré le : jeu. 18 nov. 2004 23:12
Année de naissance : 1972
Localisation : Loire atlantique
Contact :

Re: Plus de connexion site boursier

Message par Mérops »

Bonjour Ahoc,

Si tu peux afficher les éditions c'est que ActiveX Mozilla est présent.

Déjà, vois tu bien le sous menu suivant s'afficher ?

Image

J'ai regardé le code pour l'ouverture d'une URL "Site boursier", le lien utilise la fonction windows "ShellExecute" de Windows.

Je te conseille de mettre à jour Wine.
Si ça ne fonctionne toujours pas, je vais installer un Xubuntu 20-04 Lts pour tester.

Mérops, :wink:
Ahoc
Messages : 11
Enregistré le : ven. 23 avr. 2021 10:47
Année de naissance : 1953

Re: Plus de connexion site boursier

Message par Ahoc »

Bonjour Mérops
Déjà, vois tu bien le sous menu suivant s'afficher ?
Après avoir cliquer sur la valeur et sur site boursier, je n'ai pas ce menu, je n'ai que des informations sur le valeur.
Capture d’écran_2021-04-25_09-02-01.png
Capture d’écran_2021-04-25_09-02-01.png (39.73 Kio) Vu 3732 fois
Je pense que ma version de wine est à jour, mais je ne sais pas comment connaître la version qui est installée.

Merci de ton aide.
Amitiés
Mérops
Site Admin
Messages : 4383
Enregistré le : jeu. 18 nov. 2004 23:12
Année de naissance : 1972
Localisation : Loire atlantique
Contact :

Re: Plus de connexion site boursier

Message par Mérops »

Bonjour Ahoc,

Si tu peux vérifier que dans tes préférences générales, tu as au moins 1 site :

Image

Peux-tu me dire si les liens depuis les menus comme "FAQ" et "Aide" fonctionnent.

Image

Mérops, :wink:
Ahoc
Messages : 11
Enregistré le : ven. 23 avr. 2021 10:47
Année de naissance : 1953

Re: Plus de connexion site boursier

Message par Ahoc »

Re bjr
Si tu peux vérifier que dans tes préférences générales, tu as au moins 1 site :
Je n'ai qu'un site Abc bourse
Capture d’écran_2021-04-25_10-51-28.png
Capture d’écran_2021-04-25_10-51-28.png (53.49 Kio) Vu 3728 fois
Peux-tu me dire si les liens depuis les menus comme "FAQ" et "Aide" fonctionnent.
Assistant - forum -faq - aide : ne fonctionnent pas
Mise à jour - afficher logs - à propos : fonctionnent.
Ahoc
Messages : 11
Enregistré le : ven. 23 avr. 2021 10:47
Année de naissance : 1953

Re: Plus de connexion site boursier

Message par Ahoc »

Ma version de Wine installée : Wine 5.0-3ubuntu1
C'est la version disponible dans les dépôts Unbuntu.
Mérops
Site Admin
Messages : 4383
Enregistré le : jeu. 18 nov. 2004 23:12
Année de naissance : 1972
Localisation : Loire atlantique
Contact :

Re: Plus de connexion site boursier

Message par Mérops »

Ahoc,

Tu n'aurais pas installé récemment un nouvel antivrius ou modifié ton paramétrage qui bloquerait les ouvertures de lien de Mérops ?

Mérops, :wink:
Ahoc
Messages : 11
Enregistré le : ven. 23 avr. 2021 10:47
Année de naissance : 1953

Re: Plus de connexion site boursier

Message par Ahoc »

Bsr
Tu n'aurais pas installé récemment un nouvel antivrius ou modifié ton paramétrage qui bloquerait les ouvertures de lien de Mérops ?
Je n'ai pas d'antivirus sous linux et je n'ai pas changé le paramétrage.

Il y a une quinzaine de jours, j'ai réinstallé Mérops pour mise à jour.

Amitiés
Mérops
Site Admin
Messages : 4383
Enregistré le : jeu. 18 nov. 2004 23:12
Année de naissance : 1972
Localisation : Loire atlantique
Contact :

Re: Plus de connexion site boursier

Message par Mérops »

Adhoc,

Si tu peux dans l'ordre tant que ça ne fonctionne pas :
- vérifier dans ton paramétrage que tu as bien un navigateur défini par défaut (une vidéo pour le faire sur Windows, tu devrais avoir l'équivalent sur Linux https://www.youtube.com/watch?v=3oSUEIdCZrw )
- réinstaller ton navigateur internet
- installer un nouveau navigateur internet

Mérops, :wink:
Ahoc
Messages : 11
Enregistré le : ven. 23 avr. 2021 10:47
Année de naissance : 1953

Re: Plus de connexion site boursier

Message par Ahoc »

Bonjour Mérops

Capture d’écran_2021-04-26_07-59-19.png
Capture d’écran_2021-04-26_07-59-19.png (78.33 Kio) Vu 3708 fois
Voilà la liste de mes navigateurs, c'était Navigateur Web Chromium qui était paramétré par défaut .
J'ai installé un nouveau navigateur, Opéra, pour voir, mais ça ne change rien.
Quel que soit le navigateur par défaut sélectionné , c'est Firefox qui se lance quand je clique sur un lien,
dans n'importe quel document.
Amitiés
kikela
Messages : 58
Enregistré le : mar. 09 juin 2020 8:37
Année de naissance : 1955

Re: Plus de connexion site boursier

Message par kikela »

Bonjour,
et si, pour voir, tu désinstallais Firefox ?

je sais que sous linux (mandriva à l'époque) il me posait beaucoup de problèmes...

cordialement,

Kikela
Ahoc
Messages : 11
Enregistré le : ven. 23 avr. 2021 10:47
Année de naissance : 1953

Re: Plus de connexion site boursier

Message par Ahoc »

bjr et merci pour ton aide
J'hésite à désinstaller Firefox car Mérops travaille sous Wine et je ne sais pas quel explorateur est utilisé par Wine.
De plus, Firefox a été paramétré pour optimisation avec un disque SSD et je ne suis pas sur de pouvoir le refaire au cas ou.
Mérops fonctionnait très bien il y encore quelques temps, et c'est probablement suite à une mise à jour de Mérops que j'ai ce problème.
J'attends une réponse de "Mérops" qui m"assiste aussi sur ce post, avant de continuer.
Amitiés.
Mérops
Site Admin
Messages : 4383
Enregistré le : jeu. 18 nov. 2004 23:12
Année de naissance : 1972
Localisation : Loire atlantique
Contact :

Re: Plus de connexion site boursier

Message par Mérops »

Bonjour Ahoc,

La solution n'est pas cotée Mérops mais sur votre PC.
Ces menus liens, faq, ... ne font qu'exécuter la commande basique Windows ShellExecute qui lance le programme associé à l'extension.

Sur le lien https://www.linuxquestions.org/question ... 175447768/
on peut lire :
J'ai juste eu le même problème en adaptant mon programme Windows à wine sur ubuntu.

Si wine a été installé avant Internet Explorer resp. les DLL Windows nécessaires pour les opérations HTTP, les liens appropriés pour ouvrir les URL dans le navigateur par défaut ne seront évidemment pas créés. Retirer et réinstaller wine (même la même version) est suffisant pour que cela fonctionne à nouveau!
Il faudrait que tu désinstalles Wine puis que tu le réinstalles.

Mérops, :wink:
Répondre